Vista – Visual Studio 2005 Install Tip

Saturday 4th March, 2006 at 8:57 pm 5 comments

Note: I haven’t yet checked this on other Vista builds!

When installing Visual Studio 2005 — it’s best to install Visual Studio BEFORE you add/remove programs.  Things can get messed up really quickly if you don’t (hence todays Vista reinstall).  The .NET Framework 2 comes preinstalled with the OS and if something else you have installed touches the framework in any way or installs a previous version of the framework – Visual Studio just won’t install.

I had a whole host of problems getting VS 2005 installed and it turned out that another app had installed the 1.1 NET Framework.  As .NET 2 was installed by the OS – I wasn’t able to reinstall or update it.

I have noticed some differences between Vista Business and Vista Ultimate (such as how the sidebar gadget operated) – weird because the media was the same – only the license key differed.

 

Advertisements

Entry filed under: .NET, Microsoft, Vista, Visual Studio, x64.

Sponsors/Funding… OO Defrag Version 8 on Vista

5 Comments Add your own

  • 1. Michial Thompson  |  Friday 9th February, 2007 at 7:41 pm

    I fully expected to have problems with Software and Vista, but I figured that it would be with third party software, NOT with Microsoft’s products.

    I bought a new laptop the day Vista was released with Vista pre-installed, and the first thing I did when I got home was install Visual Studio 2005 Pro, and then SP1, and VS is almost useless, its basically a glorified editor with Front Page extenstions…

    The Intellisense is broken, the property window sits blank all the time…

    In addition to VS2005, 3/4 of the software I use doesn’t work right with the scroll wheel on the mouse, what a joke…. I wonder if HP will give me a free copy of XP this $2k boat anchor.

    Reply
  • 2. Norm  |  Thursday 22nd February, 2007 at 5:11 pm

    I am testing this out myself. You can’t do anything without right clicking and open as administrator.

    MS should have put an option to elivate your rights at login rather then forcing you to do it at each launch of your apps.

    Even IE needs to be run in admin mode and VS (not that I have found) hasn’t got an option to launch IE in admin mode.

    It blows chunks.

    same thing with SQL server. what a pain.

    Reply
  • 3. Ronald Weasley  |  Sunday 11th November, 2007 at 2:52 pm

    Have to agree. Vista gave me no problems at first when I tried it our for a couple of games…then installshield went ape and I landed up having to reinstall vista.

    Everything went well for a short while until I decided that I’d give development a go on Vista – HAHAHAHA. Messages and errors during the install…downloading 500 megs of services packs and hotfixes and then “Package load failure” errors. Tried several “tips and tricks” to fix these issues but none worked (including Visual Studio repairs, re-installs, the “magic” ttool (visual studio troubleshooting tool) and still NADA!

    I was starting to like Vista until this crap started…now I can’t even install paint.net. Other programs I run give me the “Program X has stopped working” error…crap even excel crashes frequently.

    Now the horrible but rewarding task of taking this crap off my machine and moving back to good ol’ win xp…may not look as nice but at least it works…hope vista burns in hell.

    Reply
  • 4. godson antony  |  Friday 20th February, 2009 at 7:46 am

    hai

    i have faced prblem in instalation of visual studio 2005 in my vista laptop pls hel me

    i try to install ms studio 2005 then get error msg

    i copy my error msg
    [01/08/09,08:15:43] Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU: [2] ERROR:Error 1935.An error occurred during the installation of assembly ‘Microsoft.VC80.DebugCRT,type=”win32″,version=”8.0.50727.42″,publicKeyToken=”1fc8b3b9a1e18e3b”,processorArchitecture=”x86″‘. Please refer to Help and Support for more information. HRESULT: 0x80070422.
    [01/08/09,08:15:43] Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU: [2] ACTION FAILURE:Action ended 08:15:43: InstallFinalize. Return value 3.See MSI log for details.
    [01/08/09,08:17:10] Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU: [2] ACTION FAILURE:Action ended 08:17:10: INSTALL. Return value 3.See MSI log for details.
    [01/08/09,08:17:44] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InstallManagerHelper() with HRESULT -2147023293.
    [01/08/09,08:17:44] setup.exe: [2] Component error string not specified in ISetupManager::AddToActionResultCollection()
    [01/08/09,08:17:45] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU is not installed.
    [01/08/09,08:17:45] VS70pgui: [2] Unknown component status forMicrosoft SQL Server 2005 Express Edition x86
    [01/08/09,08:18:42] VS Scenario: [2] *** Blocking Components exist and must be satisified before continuing to install ***
    [01/08/09,08:18:42] VS Scenario: [2] Windows XP Service Pack 2 Update Information
    [01/08/09,08:18:42] VS Scenario: [2] *** End of Blocking Component List ***
    [01/08/09,08:18:54] VS Scenario: [2] Failed to pass the Warnings/Blocks checks in CVSScenario::Start()
    [01/08/09,08:28:49] Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU: [2] ERROR:Error 1935.An error occurred during the installation of assembly ‘Microsoft.VC80.DebugCRT,type=”win32″,version=”8.0.50727.42″,publicKeyToken=”1fc8b3b9a1e18e3b”,processorArchitecture=”x86″‘. Please refer to Help and Support for more information. HRESULT: 0x80070422.
    [01/08/09,08:28:49] Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU: [2] ACTION FAILURE:Action ended 08:28:49: InstallFinalize. Return value 3.See MSI log for details.
    [01/08/09,08:30:23] Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU: [2] ACTION FAILURE:Action ended 08:30:22: INSTALL. Return value 3.See MSI log for details.
    [01/08/09,08:30:59] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InstallManagerHelper() with HRESULT -2147023293.
    [01/08/09,08:30:59] setup.exe: [2] Component error string not specified in ISetupManager::AddToActionResultCollection()
    [01/08/09,08:31:00] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio 2005 Tools for the Microsoft Office System – ENU is not installed.
    [01/08/09,08:31:00] VS70pgui: [2] Unknown component status forMicrosoft SQL Server 2005 Express Edition x86

    Reply
    • 5. tbmr  |  Thursday 27th January, 2011 at 9:35 pm

      I have this problem too. i have vista, and i dont know what to do about it… please help…

      Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Trackback this post  |  Subscribe to the comments via RSS Feed


Recent Posts


%d bloggers like this: